博威---云架构决胜云计算

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
楼主: network

VMware ESX4使用大全

[复制链接]
 楼主| 发表于 2010-12-24 08:45:42 | 显示全部楼层
VMware虚拟化在电信行业的应用


IT是一个充满创新与激情的行业,几乎每隔一段时间,就会有一种新的技术革新成为市场的热点。而最近几年,随着IT技术发展的日新月异,大量高性能、高整合率而又异构的基础硬件平台不断涌现,虚拟化日渐成为了新的热点:服务器虚拟化、存储虚拟化、网络虚拟化,越来越成为人们耳熟能详的词汇,所有主要的IT厂商也都在推波助澜,似乎大有让这股潮流演变成海啸之势。但是虚拟化到底是做什么用的呢,它究竟能给复杂多变而又充满挑战的IT运维环境带来怎样的影响呢?本文就以电信行业为例,看看虚拟化从中起到了怎样的积极作用。 Svn中文网
由于虚拟化所涉及的领域非常广泛,不同的厂商对虚拟化又有着不同的诠释,不可能一概而论,所以本文着重探讨的是服务器领域的虚拟化,特别是被称为工业标准服务器的X86架构服务器(也即人们通常俗称的PC服务器)的虚拟化。 参考资料:www.svn8.com
之所以以电信行业为例,是因为在任何一个现代化的国家里,电信公司都是具有举足轻重地位的代表性大企业,而电信的机房里更是集各种最新最高精尖的IT技术之大成,一种新的IT技术或解决方案,如果没能在电信的机房里占据一席之地,就很难说它真的是一个市场热点。
参考资料:www.svn8.com
也许有人会说:“你要用电信行业为例来讨论X86架构服务器的虚拟化,是不是不太现实?据我所知,电信核心业务几乎都是运行在UNIX服务器上,即使有少量X86服务器,运行的也不过是些非关键性的业务,有必要做虚拟化吗?” 参考资料:www.svn8.com
这种说法言之有理却又失之偏颇,没错,基于对性能和高可用性的考虑,目前的电信主流核心应用运行的平台仍然是以UNIX服务器为主,而这些UNIX服务器大都具有自身特有的基本虚拟化特性,如逻辑分区功能。但是不能否认的是除了这些关键性的核心应用外,仍然有很多似乎不那么关键,不那么重要的应用是运行在X86架构的服务器上的,而这些应用之所以被认为不那么关键和重要,也许仅仅是由于以前技术上的限制,无法让其所运行的X86架构服务器具备UNIX服务器的高性能和高可用性,因为没有一个企业能把内部的所有应用都一视同仁的“关键化”“核心化”,那样的话,意味着所有的应用都要运行在成本相对高昂、对管理使用技能要求更高的UNIX服务器上甚至是大型机上,部署与维护的成本将会难以估量。可是那些“非关键性”的X86架构服务器所带来的维护管理上的麻烦并不会因此而减少,很多时候,由于X86架构服务器的典型一对一部署方式,即一台服务器部署一个应用,造成服务器数量大量分散,且出现问题的时候,又缺乏有效的方式来及时恢复,只能是靠睁一只眼闭一只眼的方式应付过去,人为的“不关键”起来。 Svn中文网
但是如果有一种方法能够改变这种现状,在不增加更多的成本,不改变基础硬件平台,同时对用户现有的环境又不会造成太大的影响情况下,实现了X86架构的高度整合率、高管理性与高可用性,我想没有人会真的拒绝。而X86架构服务器的虚拟化就是这种有效的解决途径之一,而且是非常重要的一个途径。
Svn中文网
如前所述,虚拟化的含义非常广泛,一种比较通俗的定义就是:“简单来说,虚拟化就是淡化用户对于物理计算资源,如处理器、内存、I/O设备的直接访问,取而代之的是用户访问逻辑的资源,而后台的物理连接则由虚拟化技术来实现和管理”。这个定义形象的说明了虚拟化的基本作用,其实就是要屏蔽掉传统方式下,用户部署应用时需要考虑的物理硬件资源属性,而是更着重于应用真正使用到的逻辑资源,如CPU主频Hz,内存大小等。 Www.Svn8.Com
虚拟化产品是逐渐成熟与完善的,第一代的虚拟化产品通过一个hypervisor或者是主机的架构提供了服务器的分区能力。第二代的虚拟化技术增加了虚拟化的管理、生产力的规划、物理服务器到虚拟机的迁移已经其他的工具用于整合生产服务器。而X86架构服务器虚拟化的市场开拓者与领导者VMware的第三代虚拟架构(VI3),则代表了新一代的虚拟化技术,该虚拟架构重新定义了一个新的IT标杆,它将工业标准服务器和存储虚拟化组成了一个整体,聚合成一个动态的可集中管理的资源池,可使任何应用或操作系统保持持续优化和高可用状态。它使得企业有能力去转化、管理和优化他们的IT系统架构。VMware的虚拟架构可以让用户的数据中心被整合成一个单一的包括处理器、存储和网络连接的资源池。

在一个虚拟架构中,用户可以把资源看成是专属于他们的,而管理员则可在企业范围内管理和优化整个资源。VMware的虚拟架构可以通过增加效率、灵活性和响应能力来降低企业的IT花费。管理一个虚拟架构可以让IT部门更快的连接和管理资源,以满足商业所需。

Svn中文网


虚拟架构可以让IT部门达成以下目标: Www.Svn8.Com


● 35%-75% TCO 节省 Www.Svn8.Com 通过将整合多个物理服务器到一个物理服务器降低40%软件硬件成本; 参考资料:www.svn8.com


整合比:生产环境10-15 : 1 ,开发测试环境15-20 : 1; Bbs.Svn8.Com 每个服务器的平均利用率从5%-15%提高到60%-80%;

Bbs.Svn8.Com


降低70-80%运营成本, 包括数据中心空间、机柜、网线,耗电量,冷气空调和人力成本。 参考资料:www.svn8.com


● 提高运营效率 Bbs.Svn8.Com 部署时间从小时级到分钟级, 服务器重建和应用加载时间从 20-40 hrs =>15-30 min, 每年节省10,000 人/小时(300台服务器);

Svn中文网



以前硬件维护需要之前的数天/周的变更管理准备和1 - 3小时维护窗口,现在可以进行零宕机硬件维护和升级。 参考资料:www.svn8.com ● 提高服务水平 Www.Svn8.Com

帮助您的企业建立业务和IT资源之间的关系,使IT和业务优先级对应;

参考资料:www.svn8.com



将所有服务器作为大的资源统一进行管理,并按需自动进行动态资源调配; 参考资料:www.svn8.com 无中断的按需扩容。 参考资料:www.svn8.com


● 旧硬件和操作系统的投资保护 Www.Svn8.Com 不再担心旧系统的兼容性,维护和升级等一系列问题。 Svn中文网

下面来针对几种电信领域常见的应用场景进行分析,来看看虚拟化给电信运营环境所带来的一些帮助。

Svn中文网


Www.Svn8.Com

参考资料:www.svn8.com



1、电信机房基于X86架构的数据库及应用服务器整合: Bbs.Svn8.Com
虽然目前绝大部分的电信核心应用都是运行在UNIX服务器系统之上,但是仍然会有一些应用运行在X86架构服务器上,如一些OA系统,邮件服务器等,甚至包括Windows的AD域控制服务器、DNS服务器、Web服务器、企业杀毒软件服务器等等。传统的方式下,这些应用几乎都是采用的一对一的模式来部署的,因为在缺乏高可用性的保证下,没有哪个人会把所有的鸡蛋放在一个篮子里,独自承担这种巨大的风险。 Svn中文网 ● 特点:

Svn中文网


分散部署,缺乏有效的高可用性保障,管理困难,部署麻烦。

参考资料:www.svn8.com



● 解决方案: Www.Svn8.Com
VMware虚拟架构(VI3)+高端高性能服务器组。 Www.Svn8.Com
● 方案优势: Www.Svn8.Com
可实现集中化管理,模板式部署,通过VI3产品套件中提供的,HA、VMotion、DRS等特性,具有了高可用性保证,易于实现灾备目标,可方便的实现在线迁移与零宕机维护,提高服务级别。 Www.Svn8.Com ● 应用案例: Svn8.Com


Qualcomm公司,采用VI3整合Web及数据库应用,利用VMotion技术实现零宕机系统升级维护。 Svn中文网 2、前端营业网点PC机上收整合: Svn8.Com


电信业务的一大特点就是依托于大量按地域分散部署的营业网点,虽然现在有各种各样的新型业务模式,如网上交易、电话交易等等,但这些物理存在的营业网点仍然具有着举足轻重的地位,每个网点都有用于与中心联系的通信服务器,每个柜员也都有自己的PC机用于完成相应的业务。 Svn8.Com ● 现状: Www.Svn8.Com

庞大的分散在各个网点的PC机,部署麻烦,管理困难,维护复杂,难于保障安全性和可靠性。

Bbs.Svn8.Com



● 解决方案: 参考资料:www.svn8.com
VMware虚拟架构(VI3)及虚拟桌面(VDI)解决方案+刀片或机架式服务器组。 参考资料:www.svn8.com ● 方案优势:

Svn中文网



高度集中化管理,确保高可靠性及安全性,部署方便,易于维护。 Www.Svn8.Com ● 应用案例: Www.Svn8.Com


某电信公司全省几万台营业网点PC机集中化整合与管理。 Svn8.Com 3、电信呼叫中心(Call Center):

Bbs.Svn8.Com


为了提供高效高质的客户关系管理,所有的电信公司都建有现代化的呼叫中心,成百上千的客服人员通过各自的PC终端,进行着查询客户信息、按客户要求更改业务,处理客户投诉等工作。

Www.Svn8.Com



● 特点: Bbs.Svn8.Com




大量同质化的PC客户端,部署麻烦,管理困难,维护复杂。
Bbs.Svn8.Com

● 解决方案: 参考资料:www.svn8.com
VMware虚拟架构(VI3)及虚拟桌面(VDI)+刀片或机架式服务器组。 Www.Svn8.Com
● 方案优势: Www.Svn8.Com
模板化批量部署,集中化管理,高可靠性及安全性。
Bbs.Svn8.Com

● 应用案例:
Bbs.Svn8.Com
加拿大BEll,在其呼叫中心采用上百台刀片部署将近2000个虚拟客户端,提供了集中化的管理,提高了管理维护的效率,增强了安全性。 Www.Svn8.Com

参考资料:www.svn8.com

Bbs.Svn8.Com
4、开发测试中心:
Www.Svn8.Com
为了保持行业领先地位,需要电信企业具有持续发展的能力,不断开发出新的业务品种出来,因此做为这种创新能力的体现之一的开发测试中心,就显得尤为重要了。而这些开发测试中心中,也使用着大量的X86架构服务器。 Svn8.Com
● 特点: Bbs.Svn8.Com
服务器蔓延无序,系统设置与设立方面开销庞大,低价值重复性装机工作量大,资源难于共享,缺陷的再现与故障处理困难。
Www.Svn8.Com
● 解决方案: Bbs.Svn8.Com
VMware虚拟架构(VI3)及实验室管理(lab Manager)+高端高性能服务器。
Bbs.Svn8.Com

● 方案优势:
Svn中文网
整合并高效地共享实验室资源;可以自助的方式,安全地进行资源“签出”和设立,同时保持IT部门对实验室的控制;能够可靠地进行软件缺陷的再现、故障处理和解决。 参考资料:www.svn8.com
● 应用案例:
Svn8.Com

Juniper Network,总计使用了400多台测试服务器,通过采用VMware VI3及实验室管理解决方案,每个测试周期的测试案例可达1万4千多个,极大地提高了开发测试效率,提升了产品品质。
Www.Svn8.Com

5、数据中心的灾难备份(X86平台):
Bbs.Svn8.Com
电信机房至关重要,为此企业不惜投入重金来确保其能长期稳定可靠的运行,但是天灾人祸总难免, 不怕一万,就怕万一,一次灾难性的事件发生,可能就会给企业带来灭顶之灾,所以很多企业都开始或者正在计划部署灾难恢复系统,而大量的X86架构服务器上的应用如何进行灾难保护呢。 参考资料:www.svn8.com
● 特点:
Svn8.Com

传统的数据中心灾难备份投资高昂、实现复杂、维护困难、可靠性低,大多只是实现了数据级的灾备。 Svn8.Com
● 解决方案:
Svn8.Com
VMware虚拟架构(VI3)+高端高性能服务器组+高端高性能光纤磁盘阵列。 Svn8.Com
● 方案优势: Svn中文网
有效减少计划内及计划外宕机时间,降低成本和复杂性,改善灾难恢复,提高可靠性,不需要升级灾备中心的服务器以及和主中心一对一的服务器硬件,易于自动化,不需要裸机恢复,实现应用级乃至业务级灾备。
参考资料:www.svn8.com

● 应用案例:
参考资料:www.svn8.com

某电信公司,通过VMware解决方案实现生产中心的灾难备份,达成业务连续性目标,在一次实际灾备切换中,仅用16分半钟时间在灾备中心恢复了400个虚拟机。
参考资料:www.svn8.com

6、IDC:
Bbs.Svn8.Com

IDC是电信行业的一个特殊领域,通过提供主机托管、虚拟主机业务等方式,IDC的机房承载着互联网世界中大部分的访问负载。众多的知名网站,都将自己的服务器部署在IDC的机房中。 Svn中文网
● 特点:
Www.Svn8.Com
大量服务器集中部署,对空间、能耗、网络环境的要求都非常高,其客户的要求多变且难以预测。
Bbs.Svn8.Com
● 解决方案:
Www.Svn8.Com
VMware虚拟架构(VI3)+高端高性能服务器组。 Svn8.Com
● 方案优势:
参考资料:www.svn8.com
整合并高效地共享服务器资源;快速的响应能力,可随业务变化及时做出调整,对空间、能耗、网络环境的要求相对较低,可提供增值服务。 Www.Svn8.Com
本文来自Svn中文网[www.svn8.com]转发请保留本站地址:http://www.svn8.com/vps/VMware/vps2010081549639_3.html
 楼主| 发表于 2010-12-24 08:50:58 | 显示全部楼层
VMware ESXi 常见问题解答

VMware 为何要免费提供 ESXi?

VMware 目前免费提供独立的 ESXi 管理程序,旨在让各种规模的公司都能体验虚拟化的好处。由于 ESXi 具有创新型体系结构、安装简单并且具备高性能,因此客户对它表现出了极大的兴趣。通过让 IT 管理员免费获得 VMware ESXi,每个人都可以接触到 VMware 的数据中心技术,并在自己的公司证明它的价值所在。

我能否获得针对 VMware ESXi 的支持服务?
免费使用 VMware ESXi 产品的客户可以获得多种支持选项。

我能否在 VMware ESXi 上运行通过 Microsoft Virtual Server、Microsoft Virtual PC 或 VMware Server 创建的虚拟机?

可以。您可以使用免费的 VMware vCenter Converter 导入使用 VMware Server、Microsoft Virtual Server 或 Microsoft Virtual PC 第 7 版或更高版本创建的虚拟机。VMware vCenter Converter 还支持从物理机以及某些第三方磁盘映像格式等源进行转换。 有关详细信息,请查看 VMware vCenter Converter 常见问题解答。

我可以使用何种工具来管理我的免费 VMware ESXi 许可证?

VMware 建议使用 VMware vSphere Client 来管理 VMware ESXi。您也可以使用 vSphere Command-Line Interface 4.0 (vCLI) 来查询 VMware ESXi 主机。请注意,免费版 VMware ESXi 不允许通过 vCLI 对 VMware ESXi 主机进行任何配置更改。此外,使用 VMware vCenter Server 管理 VMware ESXi 主机时要求每台主机都拥有 VMware vCenter Server Agent 许可证;所有版本的 VMware vSphere 中都包含此许可证。

VMware ESX 与 VMware ESXi 有何差别?

VMware ESX 和 VMware ESXi 都是直接安装在服务器硬件上的裸机管理程序。二者均具有业界领先的性能和可扩展性,不同之处在于 VMware ESXi 采用了独特的体系结构和操作管理方法。尽管二者都不依赖操作系统进行资源管理,但 VMware ESX 依靠 Linux 操作系统(称作服务控制台)来执行以下两项管理功能:执行脚本,以及安装用于硬件监控、备份或系统管理的第三方代理。

ESXi 中已删除了服务控制台,从而大大减少了此管理程序的占用空间,实现了将管理功能从本地命令行界面迁移到远程管理工具的发展趋势。更小的 ESXi 代码库意味着“受攻击面”更小,需要修补的代码也更少,从而提高可靠性和安全性。服务控制台的功能由符合系统管理标准的远程命令行界面取代。查看 VMware ESX 与 VMware ESXi 管理的详细对比。

VMware ESXi 与 VMware vSphere 有何不同?

VMware ESXi 是一种虚拟机管理程序,可将一台物理服务器划分为多个虚拟机。VMware vSphere 是业界首款云操作系统,可大大降低日常成本,增强对所提供服务级别的控制,同时仍然保留了在任何类型的操作系统、应用程序与硬件体系结构间进行选择的灵活性。VMware vSphere 可为组织提供跨多个 ESXi 主机的高可用性和集中管理功能,例如实时迁移、硬件故障防范、电源管理和自动负载平衡。VMware vSphere 依赖虚拟机管理程序对服务器进行分区。

客户可以选择将 VMware ESX 或 VMware ESXi 作为 VMware vSphere 套件的一部分进行部署。VMware vSphere 的所有功能在 VMware ESX 和 VMware ESXi 上均受支持。事实上,VMware vSphere 支持同时包含这两种管理程序的服务器资源池。

我如何使用 VMware vCenter Server 管理我的 VMware ESXi 主机?

VMware vCenter Server 针对 ESXi 主机及其虚拟机提供了集中管理功能。要使用 vCenter Server 管理 ESXi 主机,您必须拥有 vCenter Server Agent 许可证,所有版本的 VMware vSphere 中均包含此许可证。

VMware ESXi 与 VMware Server 之间有何区别?

VMware ESXi 是一种企业级管理程序,它提供在性能方面接近于本机水平的裸机体系结构、用于提高整合率的内存重复数据消除等功能,以及用于管理共享存储中的虚拟机文件的集群文件系统。VMware ESXi 和 VMware ESX 是构建动态、灵活的虚拟基础架构的关键基础。

VMware Server 以应用程序的形式安装在 Windows 或 Linux 上,依靠操作系统进行资源管理。这限制了其性能和可扩展性。VMware Server 常用于测试和开发活动。使用 VMware Server 创建的虚拟机可在 VMware ESXi 上运行,但必须先使用免费的 VMware vCenter Converter 对它们进行转换。

我可以购买预安装在服务器上的 VMware ESXi 吗?

VMware ESXi 是业界第一款与硬件集成的虚拟机管理程序。Dell、IBM、HP 和 Fujitsu-Siemens 已经开始提供嵌入了 ESXi 的服务器设备。其他一些 OEM(如 NEC 和 Fujitsu)厂商也纷纷宣布即将提供预安装了 ESXi 的服务器。有关预安装了 VMware ESXi 的服务器模型的完整列表,请查看ESXi 对硬件有哪些要求?

经认证,VMware ESXi 的单行版可在硬件兼容性列表 (HCL) 中列出的硬件上运行。随着我们使越来越多的服务器通过运行 ESXi 的认证,此列表还会不断加长。有关对硬件的最低要求,请参阅 ESXi 安装指南。

哪些操作系统可以运行 ESXi?

与任何其他虚拟化供应商相比,VMware 提供了最广泛的操作系统支持。有关受支持的客户操作系统的完整列表,请访问客户操作系统兼容性指南。

VMware vCenter Update Manager 会对我的 ESXi 主机应用补丁程序吗?

VMware vCenter Update Manager 将同时更新 VMware ESX 和 VMware ESXi。此外还为没有安装 VMware vCenter Update Manager 的环境提供了更新实用工具。请注意:VMware ESXi 主机必须获得许可,VMware vSphere 才能使用 VMware vCenter Update Manager 对该主机应用补丁程序。

是否存在任何与 ESXi 不兼容的 VMware ESX 功能?

VMware ESXi 中不支持某些特定的网络功能,主要是那些需要通过服务控制台配置的功能。有关更多信息,请参见相应的知识库文章。

是否可以将虚拟设备下载到 ESXi 环境中进行评估?

可 以。如果您是将 VMware vSphere Client 2.5 及更高版本与 ESXi 3.5 或 ESX 3.5 或更高版本一起运行,则可以访问可下载到 ESXi 环境中进行评估的虚拟设备的列表。要访问此虚拟设备列表,请打开您的 VMware vSphere 客户端,从“文件”菜单中选择“虚拟设备”,然后选择“导入...”。当您选择“从 VMware Virtual Appliance Marketplace 导入”并单击“下一步”后,系统会将您定向到这些虚拟设备的下载页面。
 楼主| 发表于 2010-12-24 08:52:37 | 显示全部楼层
安装 ESXi 4 ?请先弄个带缓存的SCSI卡吧。

最近为安装Oracle买了一个测试服务器,主板内置SCSI芯片,于是乎先装了ESXi 4玩玩儿,结果发现拷贝文件上去时,最大速度才 5MB/S,很是奇怪,偶可是15k转还有16MB缓存的SCSI硬盘还RAID啦,不至于这么低吧。



经过一番查阅,发现ESXi磁盘性能低下的情况很普遍,在官方和一些准官方论坛中,逐渐找到了答案:SCSI卡要加缓存,并且最好有电池....



于是淘来一块儿LSI 320-2卡,128MB缓存且带电池。安上后,通过网络往上面上传文件,速度居然达到了16MB/S,要知道偶滴局域网络才100MB带宽,况且,上传文件的时候,电脑的硬盘等一直是亮着的(疯了...)。



待装完系统后,在虚拟机里测试一下速度...
 楼主| 发表于 2010-12-25 20:38:36 | 显示全部楼层
VMkernel采用了64位内核。相对于从前的32位,64位的VMkernel性能有大幅提升。ESX 4选择64位的VMkernel是最大的改善之处。而且64位方面的改善也相应地引起了开销的降低和内存访问的改善,因此可扩展性也大大提高了。同时由于VMkernel采用了64位,硬件平台也必须相应地采用64位,这点我们倒不至于十分担心,市场上主流的硬件基本上已经全部支持64位技术。不过一些较老的服务器只能就此止步了,毕竟这是64位主流的时代了。



    据VMware资料显示ESX4相对于3.X版本性能有很大提升:相比ESX 3.0性能有30%的提高。此外,PVSCSI与LSI Logic完全虚拟化适配器相比,光纤通道I/O提高了40%,软件iSCSI的I/O提高了20%。在运行16台虚拟机的时候,ESX 4的网络吞吐量比ESX 3.5提高了80%多,而且ESX 4的VMotion资源管理性能比ESX 3.5提升了75%。同时,在运行20台虚拟机的时候,服务提供时间缩短了一半,VMware文件系统(Virtual Machine File System,VMFS)的性能也有所提高。

    另外,应用性能明显改善。针对Oracle数据库来说,装载了8个虚拟处理器的虚拟机比装载了2个CPU(8核)的物理服务器相比性能有85%的提升,每秒可以达到8900次数据库交易。针对SQL Server的话,装载了4个虚拟处理器的虚拟机比装载了1个CPU(4核)的物理服务器相比性能有90%的提升。以上这些,我们会在后续的测试中一样进行验证。
 楼主| 发表于 2010-12-25 20:53:14 | 显示全部楼层
关于vSphere的硬件兼容列表下载和查询网址

IBM System x365 IBM Intel Xeon MP (Cranford/Potomac) Series Rackmount 4 ESX 3.0.3 U1 | ESX

特地到处了电子表格,方便查询

官方查询网址:http://www.vmware.com/resources/ ... viceCategory=server
vi_systems_guide-partial.rar (18.75 KB, 下载次数: 0)
 楼主| 发表于 2010-12-25 21:43:33 | 显示全部楼层
 楼主| 发表于 2010-12-25 22:28:47 | 显示全部楼层

Cisco Nexus 1000V安装指南
Nexus 1000V是Cisco推出的第一款纯软件的虚拟交换机产品,可以在VMware虚拟化环境中提供Cisco Catalyst交换机的功能,如QoS、ACL、SPAN等。
Cisco Nexus 1000V包含VEM和VSM两部分,其中VEM运行在ESXi服务器上取代VMware原有的虚拟交换机,VSM是一个单独运行的虚拟机,提供CLI接口,用于管理和配置整个虚拟交换机。

Cisco Nexus 1000V的具体安装步骤如下:
安装环境:
ESXi 4.0 x 1 ip address: 192.168.0.10
vCenter Server x 1 ip address: 192.168.0.20
vSphere Client and RCLI x 1 ip address: 192.168.0.30
(Cisco Nexus 1000V management ip: 192.168.0.50)
1、 从www.cisco.com下载Nexus 1000V安装包,将安装包解压得到VSM和VEM安装程序。
http://tools.cisco.com/support/d … t.x?mdfid=282362725
2、 在ESXi服务器上安装并验证VEM。
将VEM目录中的cisco-vem-v100-4.0.4.1.1.27-0.4.2.zip复制到C:\Program Files\VMware\VMware vSphere CLI\bin\ 目录中,选择开始菜单中的All programs > VMware >VMware vSphere CLI > Command Prompt
C:\Program Files\VMware\VMware vSphere CLI>cd bin
C:\Program Files\VMware\VMware vSphere CLI\bin>vihostupdate.pl -i -b cisco-vem-v100-4.0.4.1.1.27-0.4.2.zip –server 192.168.0.20
C:\Program Files\VMware\VMware vSphere CLI\bin>vihostupdate.pl -q –server 192.168.0.20
3、 在vSphere Client中,选择File > Deploy OVF Template,选中VSM目录中的Nexus1000v-4.0.4.SV1.1.ova,导入VSM虚拟机。
4、 启动虚拟机,选择安装Nexus 1000V,HA模式设定为standalone,定义管理地址及网关。
5、 查看虚拟机的host-id,并根据此id在www.cisco.com上申请60天试用License。
#show license host-id
6、 将下载的License文件放在TFTP服务器,并上传到虚拟机的bootflash中。
#copy tftp://192.168.0.30/cisco.lic bootflash:
#install license bootflash:cisco.lic
#show license usage
#copy run start
7、 在vCenter Server上安装Cisco Nexus 1000V Plug-in。
用浏览器打开虚拟机管理地址,如http://192.168.0.50,下载cisco_nexus1000v_extension.xml,在vSphere Client中选择Manage Plug-in,右键点击空白处选择新建Plug-in,选择下载的xml文件并点击注册。如果注册失败,可以删除此plug-in然后重新尝试注册,具体方法见如下的Nexus 1000V安装故障解决指南。
http://www.cisco.com/en/US/docs/ … tall.html#wp1197079
8、 从VSM虚拟机连接vCenter Server,如果连接失败通常是第6步没有成功注册Plug-in。
n1000v# config t
n1000v(config)# svs connection VC
n1000v((config-svs-conn)# vmware dvs datacenter-name DC-1
n1000v((config-svs-conn)# protocol vmware-vim
n1000v((config-svs-conn)# remote ip address 192.168.0.20
n1000v(config-svs-conn)# connect
n1000v# show svs connections
9、 定义VSM和VEM通讯使用的Port Profile。
n1000v(config)# port-profile system-uplink
n1000v(config-port-prof)# switchport mode trunk
n1000v(config-port-prof)# switchport trunk allowed vlan 1
n1000v(config-port-prof)# no shut
n1000v(config-port-prof)# system vlan 1
n1000v(config-port-prof)# vmware port-group
n1000v(config-port-prof)# capability uplink
n1000v(config-port-prof)# state enabled
10、 定义其他虚拟机数据和上联通讯的Port Profile。
n1000v$ config t
n1000v(config)# port-profile vm-uplink
n1000v(config-port-prof)# switchport mode access
n1000v(config-port-prof)# capability uplink
n1000v(config-port-prof)# switchport access vlan 262
n1000v(config-port-prof)# vmware port-group
n1000v(config-port-prof)# no shut
n1000v(config-port-prof)# state enabled
n1000v(config)# port-profile data262
n1000v(config-port-prof)# switchport mode access
n1000v(config-port-prof)# switchport access vlan 262
n1000v(config-port-prof)# vmware port-group data262
n1000v(config-port-prof)# no shut
n1000v(config-port-prof)# state enabled
n1000v(config-port-prof)# copy run start
[########################################]
11、 完成上述步骤后就可以在vSphere Client中的Inventory > Networking中看到Nexus 1000V,在Nexus 1000V上点右键,选择add host,把ESXi主机添加到分布式虚拟交换机(DVS)。
12、 验证安装是否成功
n1000v# show module
Mod Ports Module-Type Model Status
— —– ——————————– —————— ————
1 0 Virtual Supervisor Module Nexus1000V active *
3 248 Virtual Ethernet Module NA ok
参考资料:
http://netemu.cn/bbs/thread-11550-1-1.html
Cisco Nexus 1000V 系列交换机支持虚拟机的网络服务

Nexus 1000V交换机单纯依靠软件实现Cisco Nexus交换机的功能。它运行在一台服务器上,能够与Hypervisor集成,提供支持VN-Link虚拟机的网络服务。


Nexus 1000V 在VMworld 2008上赢得奖项
TechTarget Inc.的SearchServerVirtualization.com上的编辑们选择Cisco Nexus 1000V交换机作为VMworld 2008的最佳新兴技术奖得主。 了解更多相关信息


Cisco Nexus 1000V 交换机采用VMware的vNetwork分布式交换框架,提供紧密集成的网络服务。它们构成服务器虚拟化战略的重要组成部分。同时,该交换机还提供与现有Cisco Nexus和Cisco Catalyst交换机一致的运行和管理方法。


Cisco VN-Link 和 Cisco Nexus 1000V交换机所提供的服务器虚拟化技术,能够为客户数据中心的所有物理或虚拟服务器提供统一的、基于策略的网络功能。


基于策略的虚拟机连接

为网络和安全服务提供实时、统一的配置
保持以虚拟机为中心的管理模式,帮助服务器管理员提高效率和灵活性

移动VM安全和网络策略

进行在线迁移时,策略会随着虚拟机一起转移,从而确保网络、安全和存储始终遵从法规要求
确保在线迁移不会受到不同网络配置的影响
提高业务连续性,加强性能管理,确保遵从法规要求

不间断的运营模式

对数据中心的虚拟机和物理服务器连接的管理和运营环境协调匹配
保持现有的VMware运营模式
通过在整个网络中确保运营的一致性和可视性,降低总拥有成本(TCO)
在服务器、网络、安全和存储团队之间提供灵活的协作,同时支持不同的机构边界和各团队的自主权
思科 Nexus 1000V虚拟交换机
Downloads
思科 Nexus 1000V虚拟交换机 (PDF – 315 KB)
产品概述
思科 Nexus™ 1000V虚拟接入交换机是一款智能软件交换机,适用于VMware ESX环境。思科 Nexus 1000V在VMware ESX管理程序中运行,支持思科® VN-Link服务器虚拟化技术,提供:
基于策略的虚拟机(VM)连接
移动VM安全保护和网络策略,以及
对服务器虚拟化和联网团队运行无干扰的操作模式。

在数据中心部署服务器虚拟化时,虚拟服务器的管理方式一般与物理服务器不同。服务器虚拟化作为特殊部署对待,从而延长了部署所需时间,增加了服务器、网络、存储和安全管理员之间需要进行的协调工作。而采用思科 Nexus 1000V,您就能拥有一个从VM到接入层、汇聚层和核心层交换机的统一网络特性集和调配流程。您的虚拟服务器能与物理服务器使用相同的网络配置、安全策略、工具和运行模式。虚拟化管理员能充分利用预先定义的、跟随VM移动的网络策略,重点进行虚拟机管理。这一全面的功能集能帮助您更快地部署服务器虚拟化并从中受益。

思科 Nexus 1000V是与VMware密切合作的结晶,它与VMware虚拟基础设施完全集成,其中包括VMware Virtual Center、VMware ESX和ESXi。您能使用思科 Nexus 1000V来管理您的VM连接,确信能保持服务器虚拟化基础设施的完整性。

产品架构
思科 Nexus 1000V交换机有两个主要组件,即在管理程序内部运行的虚拟以太网模块(VEM)和管理VEM的外部虚拟控制引擎模块(VSM)(参见图1)。

图1. 思科 Nexus 1000V架构




虚拟以太网模块
思科 Nexus 1000V虚拟以太网模块是VMware ESX或ESXi内核的一部分,能够取代VMware虚拟交换机的功能。VEM充分利用了思科和VMware共同开发的VMware 分布式虚拟交换机(DVS) API,为虚拟机提供高级网络功能。这一集成确保思科 Nexus 1000V完全了解所有服务器虚拟化活动,如VMware VMotion和Distributed Resource Scheduler (DRS)。VEM从虚拟控制引擎模块获取配置信息,执行以下高级交换功能:
服务质量(QoS)
安全:专用VLAN、访问控制列表、思科 TrustSec架构
监控:NetFlow、SPAN、ERSPAN

思科 Nexus 1000V交换机采用思科 NX-OS软件,其设计旨在取代配备VMware ESX的基本交换机。思科 Nexus 1000V提供了一个与VMware ESX内核紧密耦合的、丰富的VM管理特性集。思科 Nexus 1000V适用于1-Gbps和10-Gbps架构,并且需与现有网络基础设施集成。

如果丢失了与虚拟控制引擎模块的连接,VEM具有不间断转发功能,能根据最近了解的配置来继续交换流量。简言之,VEM为服务器虚拟化环境提供了高级交换功能和数据中心可靠性。

虚拟控制引擎模块
思科 Nexus 1000V虚拟控制引擎模块将多个VEM作为单一逻辑模块化交换机管理。用户不必再部署物理线卡模块,虚拟控制引擎模块支持服务器软件内部运行的VEM。配置可通过虚拟控制引擎模块进行并自动传播到VEM。管理员无需每次在一台主机上的管理程序内部配置软交换机,而是能够在所有由虚拟控制引擎模块管理的VEM上定义配置并立即使用。

思科 VN-Link的核心是一个称为端口简况的思科 NX-OS特性。端口简况是一系列网络属性,如VLAN分配、服务质量(QoS)参数、访问控制列表(ACL)配置和其他过去应用于特定网络接口的网络特性。与需要分别配置各端口的传统网络调配不同,端口简况能够在一组端口上同时部署。

通过思科 NX-OS的功能,思科 Nexus 1000V提供以下优势:
灵活性和可扩展性:按类别配置端口,使解决方案能扩展至大量端口。包括局域网和存储局域网在内的所有数据中心网络区域都能运行通用软件。
高可用性:同步冗余控制引擎支持基于状态的快速故障切换。
可管理性:通过思科命令行界面(CLI)、SNMP和XML API接入思科 Nexus 1000V。

与思科 Nexus系列的其他产品一样,思科 Nexus 1000V也能通过全面的思科数据中心网络管理器工具进行管理。此外,思科 VFrame Data Center还能控制思科 Nexus 1000V,以便虚拟数据中心进行全面协调。

虚拟控制引擎模块也能与VMware Virtual Center集成,以便虚拟化管理员能充分受益于思科 Nexus 1000V中的网络配置。

特性和优势
思科 Nexus 1000V通过包括基于策略的VM连接、VM安全和网络属性的移动性以及对运行无干扰的操作模式等思科 VN-Link技术,为您提供了一个通用的物理和虚拟基础设施管理模式。

基于策略的VM连接:为了使VM的创建和调配更轻松,思科 Nexus 1000V包括了端口简况特性,能从网络角度支持服务器虚拟化的动态特性(参见图2)。端口简况允许您为不同类型或级别的VM定义VM网络策略,然后通过VMware Virtual Center GUI应用它们,以透明地调配网络资源。端口简况是一个为网络配置大量VM的可扩展机制。

图2. 基于策略的VM连接




VM安全和网络属性的移动性:端口简况中定义的网络和安全策略在VM的生命周期中始终跟随VM移动,无论它从一个服务器迁移到另一服务器(参见图3)、挂起、睡眠还是重启,均是如此。除迁移策略外,思科 Nexus 1000V虚拟控制引擎模块还能移动VM的网络状态,如端口计数器等。进行思科 NetFlow或ERSPAN等流量监控活动的VM能继续这些活动,不受VMotion操作的影响。当更新端口简况时,思科 Nexus 1000V自动向所有使用此端口简况的端口提供实时更新信息。借助通过VMotion迁移网络和安全策略的能力,能够更加轻松地实现法规遵从性,这是因为其安全策略定义方式与物理服务器相同,由思科 Nexus 1000V持续实施。

图3. 网络和安全属性的移动性




无干扰型操作模式:由于与VMware Virtual Center紧密集成,思科 Nexus 1000V允许虚拟化管理员继续使用VMware工具来调配VM。同时,网络管理员能使用思科 CLI、SNMP、XML API以及ERSPAN和NetFlow等工具,就像调配和操作物理网络一样,来调配和操作VM网络。虽然两个团队使用常用工具独立工作, 但思科 Nexus 1000V能在服务器虚拟化环境中实施一致的配置和策略。这种集成降低了拥有成本,并支持服务器、网络、安全和存储团队之间的各种机构边界。

在VMware Virtual Center内部,VM的配置和以前一样。现在,您无需在Virtual Center中定义网络配置,思科 Nexus 1000V控制引擎上定义的端口简况即可在Virtual Center中作为端口组显示。虚拟化管理员能充分利用预先配置的端口组,重点进行VM管理,而网络管理员则能使用端口简况来配置大量端口。这两个团队携手,便能更高效地部署服务器虚拟化,降低运营开支


 楼主| 发表于 2010-12-25 22:38:58 | 显示全部楼层
Nexus 1000V是Cisco推出的第一款纯软件的虚拟交换机产品,可以在VMware虚拟化环境中提供Cisco Catalyst交换机的功能,如QoS、ACL、SPAN等。         Cisco Nexus 1000V包含VEMVSM两部分,其中VEM运行在ESXi服务器上取代VMware原有的虚拟交换机,VSM是一个单独运行的虚拟机,提供CLI接口,用于管理和配置整个虚拟交换机。








Cisco Nexus 1000V的具体安装步骤如下:


安装环境:
ESXi 4.0 x 1
ip address:
192.168.0.10

vCenter Server x 1
ip address:
192.168.0.20

vSphere Client and RCLI x 1
ip address:
192.168.0.30

Cisco Nexus 1000V
management ip 192.168.0.50



1、
www.cisco.com下载Nexus 1000V安装包,将安装包解压得到VSMVEM安装程序。
http://tools.cisco.com/support/downloads/pub/Redirect.x?mdfid=282362725

2、
ESXi服务器上安装并验证VEM
VEM目录中的cisco-vem-v100-4.0.4.1.1.27-0.4.2.zip复制到C:\Program Files\VMware\VMware vSphere CLI\bin\ 目录中,选择开始菜单中的All programs > VMware >VMware vSphere CLI > Command Prompt
C:\Program Files\VMware\VMware vSphere CLI>cd bin
C:\Program Files\VMware\VMware vSphere CLI\bin>vihostupdate.pl -i -b cisco-vem-v100-4.0.4.1.1.27-0.4.2.zip --server 192.168.0.20
C:\Program Files\VMware\VMware vSphere CLI\bin>vihostupdate.pl -q --server 192.168.0.20

3、
vSphere Client选择File > Deploy OVF Template选中VSM目录中的Nexus1000v-4.0.4.SV1.1.ova导入VSM虚拟机。
4、
启动虚拟机,选择安装Nexus 1000VHA模式设定为standalone,定义管理地址及网关。
5、
查看虚拟机的host-id,并根据此idwww.cisco.com上申请60天试用License
#show license host-id
6、
将下载的License文件放在TFTP服务器,并上传到虚拟机的bootflash中。
#copy tftp://192.168.0.30/cisco.lic bootflash:


#install license bootflash:cisco.lic



#show license usage


#copy run start

7、
vCenter Server上安装Cisco Nexus 1000V Plug-in
用浏览器打开虚拟机管理地址http://192.168.0.50下载cisco_nexus1000v_extension.xmlvSphere Client中选择Manage Plug-in,右键点击空白处选择新建Plug-in,选择下载的xml文件并点击注册。如果注册失败,可以删除此plug-in然后重新尝试注册,具体方法见如下的Nexus 1000V安装故障解决指南

http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_0/troubleshooting/configuration/guide/trouble_3install.html#wp1197079

8、
VSM虚拟机连接vCenter Server,如果连接失败通常是第6步没有成功注册Plug-in
n1000v# config t
n1000v(config)# svs connection VC
n1000v((config-svs-conn)# vmware dvs datacenter-name DC-1
n1000v((config-svs-conn)# protocol vmware-vim
n1000v((config-svs-conn)# remote ip address 192.168.0.20
n1000v(config-svs-conn)# connect
n1000v# show svs connections
9、
定义VSMVEM通讯使用的Port Profile
n1000v(config)# port-profile system-uplink
n1000v(config-port-prof)# switchport mode trunk
n1000v(config-port-prof)# switchport trunk allowed vlan 1
n1000v(config-port-prof)# no shut
n1000v(config-port-prof)# system vlan 1
n1000v(config-port-prof)# vmware port-group
n1000v(config-port-prof)# capability uplink
n1000v(config-port-prof)# state enabled
10、
定义其他虚拟机数据和上联通讯的Port Profile
n1000v$ config t
n1000v(config)# port-profile vm-uplink
n1000v(config-port-prof)# switchport mode access
n1000v(config-port-prof)# capability uplink
n1000v(config-port-prof)# switchport access vlan 262
n1000v(config-port-prof)# vmware port-group
n1000v(config-port-prof)# no shut
n1000v(config-port-prof)# state enabled

n1000v(config)# port-profile data262
n1000v(config-port-prof)# switchport mode access
n1000v(config-port-prof)# switchport access vlan 262
n1000v(config-port-prof)# vmware port-group data262
n1000v(config-port-prof)# no shut
n1000v(config-port-prof)# state enabled
n1000v(config-port-prof)# copy run start
[########################################]

11、
完成上述步骤后就可以在vSphere Client中的Inventory > Networking中看到Nexus 1000VNexus 1000V上点右键选择add hostESXi主机添加到分布式虚拟交换机DVS
12、
验证安装是否成功
n1000v# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
1 0 Virtual Supervisor Module Nexus1000V active *
3 248 Virtual Ethernet Module NA ok

参考资料:
http://www.cisco.com/en/US/products/ps9902/prod_installation_guides_list.html
 楼主| 发表于 2010-12-28 12:52:01 | 显示全部楼层
 楼主| 发表于 2010-12-28 13:08:57 | 显示全部楼层
http://server.it168.com/a2010/1028/1119/000001119124.shtml



什么是“关键业务”?从IT领域的应用来看,并没有一个公认精准的定义。一般来讲,诸如ERP、CRM、数据库(分布数据库)、Web、电子商务、多应用整合等被认为是典型的关键业务应用。那么,能满足“关键业务领域”内的虚拟化服务器有哪些呢?用户该如何选型呢?

  本篇,我们将推荐多款能满足“关键业务领域”需求的虚拟化服务器。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|boway Inc. ( 冀ICP备10011147号 )

GMT+8, 2024-7-24 02:26 , Processed in 0.105940 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表